¿En qué se basa el español estructurado?

Como puede observarse, el español estructurado puede ser de utilidad para describir con claridad condiciones y acciones. Cuando se examina el ambiente de una empresa, los analistas pueden utilizar el español estructurado para declarar las reglas de decisión que se aplican las estrategias para determinar los requerimientos también se abordarán aspectos sobre la estructuración del proceso de análisis, esto es analizar un sistema existente de manera tal que se asegure la captura de todos los detalles pertinentes relacionados con dalos y procesos. El análisis estructurado tiene relación con los aspectos presentados por Mary Helen en la historia al inicio del capítulo, reconocer la naturaleza dinámica de los sistemas en las organizaciones. En este capítulo primero se explica la finalidad del análisis estructurado y después se explora el análisis de flujo de datos, resaltando la utilidad que tiene para los analistas y describiendo su uso. Cada estrategia depende de la habilidad de los analistas para hacer uso de las técnicas, estudiadas en el capítulo anterior, para detectar hechos y recopilar detalles relacionados con el sistema

¿Qué tipo de declaraciones emplea el español estructurado para describir un Proceso?

SECUENCIA
Indica que las instrucciones de un programa se ejecutan una después de la otra, en el mismo orden en el cual aparecen en el programa. Se representa gráficamente como una caja después de otra, ambas con una sola entrada y una única salida.
Las cajas ‘x’ y ‘y’ pueden ser definidas para ejecutar desde una simple instrucción hasta un módulo o programa completo, siempre y cuando que estos también sean programas apropiados.
Una estructura de programa es secuencial si se ejecutan una tras otra a modo de secuencia, es decir que una instrucción no se ejecuta hasta que finaliza

Ejemplo:
1) Declarar dos constantes e inicializarlas con los valores 10 y 20 respectivamente, sumarlas y mostrar el resultado.
c1 = 10, c2 = 20, s = 0
s = c1 + c2
Escribir (s)

2) El Idem anterior pero con los valores a sumar dinámicos.
s = 0
Leer(n1, n2)
s = n1 + n2
Escribir (s)

3) Dado el importe de una factura calcular el valor correspondiente al IVA.
iva = 0
Leer(imp)
iva = imp * 21 / 100
Escribir ("El IVA es: " iva)

SELECCIÓN
La estructura selectiva permite la realización de una instrucción u otra según un criterio, solo una de estas instrucciones se ejecutara.
También conocida como la estructura SI-CIERTO-FALSO, plantea la selección entre dos alternativas con base en el resultado de la evaluación de una condición o predicado; equivale a la instrucción IF de todos los lenguajes de programación y se representa gráficamente de la siguiente manera:

• IF (si) señala el comienzo de la instrucción condicional, y se espera que después esté la condición de control de la instrucción.
• THEN (Entonces) señala el fin de la condición, y después estará la instrucción a realizar si la condición es cierta.
• ELSE (Sino) separa la instrucción que se ejecutará si la condición es cierta de la que se ejecutará si es falsa.
• END IF (fin Si) indica que la instrucción condicional finaliza y el programa seguirá su curso.



Ejemplo:

1) División
SI (a != 0) ENTONCES
x = b/a
escribir x
SINO
escribir "Error: División por cero"
FIN_SI


2) Cuál es el numero mayor entre a, b y c

SI (a > b)
SI (a > c)
max = a;
SINO
max = c;
FIN_SI
SINO
SI (b > c)
max = b;
SINO
max = c;
FIN_SI
FIN_SI

ITERACIÓN

Un bucle iterativo o iteración de una secuencia de instrucciones, hace que se repitan mientras se cumpla una condición, en un principio el número de iteraciones no tiene porque estar determinado.

Esta instrucción tiene tres palabras reservadas WHILE, DO y WEND.

• WHILE: (mientras) señala el comienzo del bucle y después de esta palabra se espera la condición de repetición, si la condición es cierta se pasa al cuerpo del bucle, si no al final de la instrucción mientras.
• DO: (Hacer) señala el final de la condición, lo que esté después será el cuerpo del bucle.
• WEND: (Fin_mientras) señala el final del cuerpo del bucle y de la instrucción WHILE.

El bucle mientras, se repite mientras la condición sea cierta, esta condición se comprueba al principio por lo que el cuerpo del bucle puede que no se ejecute nunca, cuando la condición es falsa en un principio, o que se repita tantas veces como sea necesario, mientras la condición sea cierta.

Ejemplo:

1) Escribir los números enteros de 0 a N

Leer n = 0
num = 7
MIENTRAS num > n HACER
escribir n
n = n + 1
FIN_MIENTRAS
0 1 2 3 4 5 6


En el ejemplo tenemos dos variables n y num que al iniciarse el bucle tienen los valores n=0 y num =7.

La condición del bucle es b > num.
Cuando n=0 y num =7. La condición es cierta, en el cuerpo del bucle se escribe el valor de a en pantalla y se incrementa a en una unidad.
Entonces n=1 y num =7.
Cuando n=6 y num =7. La condición es cierta, se escribe el valor de a en pantalla y se incrementa en una unidad.
Resultando que n=7 y num =7. Entonces la condición es falsa y la instrucción mientras finaliza.
La salida por pantalla de este ejemplo seria 0 1 2 3 4 5 6

¿Qué convenciones se usan para escribir el español estructurado?
  • Exprese toda la lógica en unió de estos 4 tipos: estructuras secuenciales, de decisión, de caso.
  • Use en mayúsculas las palabras clave aceptadas como IF, THEN, ELSE, DO, DO WHILE, DO UNTIL y PERFORM.
  • Ponga sangría en los bloques de enunciados para mostrar claramente su jerarquía (anidamiento).
  • Cuando las palabras o frases se han definido en un diccionario de datos, teniendo en cuenta que hay que subrayarlas para denotar que tienen un significado especializado o reservado.
  • Tenga cuidado al usar ¨y¨ y ¨o¨ y evita la confusión al distinguir entre ¨mayor que¨ y ¨mayor que o igual¨ a ¨ u otras relaciones similares, (A y B) quiere decir tanto A como B, quiere decir cualquiera de A ó B, pero no ambos.

Para tener en cuenta en el momento del proceso: Aclare ahora los enunciados lógicos en un lugar de espera hasta la etapa de codificación del programa.

Reglas de escritura en el español estructurado:

Exprese la lógica con las estructuras:

  • Secuenciales
  • Decisión
  • Repetición

Cuando las palabras o frases se han definido por el diccionario de datos subráyelas para definir que tiene un significado especial.

Ejemplo:

DO WHILE existen conejas servidasIF monta exitosaProgramar fecha de posible partoELSEIF el número de montas es mayor a 3Programar fecha de sacrificioELSEProgramar nueva montaEND DO

Teniendo en cuenta español estructurado selectivo:


Una estructura selectiva es aquella en que se ejecutan unas acciones u otras según se cumpla o no una determinada condición. La selección puede ser simple, doble o múltiple. Se evalúa la condición y si ésta da como resultado verdad se ejecuta una determinada acción o grupo de acciones; en caso contrario se saltan dicho grupo de acciones.

Estructura Selectiva Múltiple Pseudocódigo


El siguiente ejemplo, muestra el español estructurado para el sistema de procesamiento de solicitudes de reembolso de gastos médicos.

Digitar y ubicar al inicio de las proposiciones las siguientes palabras IF, THEN, THEN IF, ELSE, ELSE IF DO, DO WHILE, ENDIF, ENDDO.

DO WHILE Haya solicitudes de reembolso pendientes

IF Solicitante no ha presentado una solicitud de reembolso

Establecer un nuevo registro del solicitante

ELSE Continuar

Agregar solicitud de reembolso a las solicitudes de reembolso

IF El solicitante tiene plan de la póliza A

THEN IF No se ha cubierto el deducible de $100.000

THEN Restar del reembolso el deducible no cubierto

Actualizar deducible

ELSE Continuar

END IF

Restar al reembolso 40% de copago

IF El solicitante tiene plan de la póliza B

THEN IF No se ha cubierto el deducible de $50000

THEN Restar del reembolso el deducible no cubierto

Actualizar deducible

ELSE Continuar

END IF

Restar al reembolso 60% de copago

ELSE Continuar

Escribir mensaje de error del plan

IF Reembolso es mayor que cero

Imprimir cheque

END IF

Imprimir resume para el solicitante

Actualizar cuentas

END DO

0 comentarios:

Publicar un comentario